ISPConfig 3

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core
  • Assigned To No-one
  • Operating System All
  • Severity Very Low
  • Priority Normal
  • Reported Version GIT/Master
  • Due in Version 3.0.2
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: ISPConfig 3
Opened by Fabio Fantoni (Fantu) - 2010-02-26
Last edited by Till (Till) - 2010-02-28

FS#1087 - Some problem with php 5.3

After update php5 package with apt-get on Squeeze from 5.2.12 to 5.3.1 ispc3 not work (sites and pma yes), for see http://ns3093701.ovh.net:8080/
Problem also after update
On update iscp3 from svn:
PHP Deprecated: Function set_magic_quotes_runtime() is deprecated in /usr/local/ispconfig/server/lib/config.inc.php on line 49

This task does not depend on any other tasks.

Closed by  Till (Till)
Sunday, 28 February 2010, 11:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  Thank you for fixing it in SVN.
Till (Till)
Friday, 26 February 2010, 19:45 GMT
Thats not a bug, ispconfig is made to work with older php versions too and this function is required for these php versions. Just the error reporting settings in the php.ini of the php version you installed now are wrong for ispconfig. Change:

error_reporting = E_ALL & ~E_DEPRECATED

to

error_reporting = E_ALL & ~E_NOTICE

in all php.ini files and restart apache.
Fabio Fantoni (Fantu)
Friday, 26 February 2010, 20:41 GMT
deprecate is small problem and error_reporting = E_ALL & ~E_NOTICE is already, the big problem is how not work ispc3 site, give codific error, see http://ns3093701.ovh.net:8080/
Till (Till)
Friday, 26 February 2010, 20:53 GMT
> deprecate is small problem and error_reporting = E_ALL & ~E_NOTICE

Ispconfig works fine on php 5.3 as all fedora installs use it, so you can be sure that your
problems are not realted to the php version you use except of the wrong error
reporting setting which has to be changed on fedora too (see fedora 12 perfect server guide).

> the big problem is how not work ispc3 site, give codific error, see http://ns3093701.ovh.net:8080/

Thats a complete different problem and most likely not a bug in ispconfig. Looks more like a configuration issue
as this seems not to be apache that you run there on port 8080. Most likey some config files got messed up by
updating PHP. Please check with netstat which application is listening on port 8080 on the system.
Fabio Fantoni (Fantu)
Friday, 26 February 2010, 20:58 GMT
i have mofify many parameters, some with values not recommended for safety and performance but now work
Till (Till)
Friday, 26 February 2010, 21:00 GMT
Ok. So I can close this now.

Loading...