ISPConfig 3

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Installer
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Normal
  • Reported Version 3.0.5
  • Due in Version 3.0.5.1
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: ISPConfig 3
Opened by Preissler Frantisek (Pida) - 2013-02-26
Last edited by Till (Till) - 2013-02-27

FS#2711 - Update error from 3.0.4.6 to 3.0.5 > Blank page after update

Our servers (about 20) are connected to centralized ISPConfig. Ispconfig database of each server is not local, but is saved on remote server.
Here is a very big problem to do update with this configuration. I don't know why must be databases localy on each server.

Log of update using ispconfig_update.sh:

#########################################################
#########################################################

root@isp:~# ispconfig_update.sh


--------------------------------------------------------------------------------
_____ ___________ _____ __ _
|_ _/ ___| ___ \ / __ \ / _(_)
| | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _
| | `--. \ __/ | | / _ \| '_ \| _| |/ _` |
_| |_/\__/ / | | \__/\ (_) | | | | | | | (_| |
\___/\____/\_| \____/\___/|_| |_|_| |_|\__, |
__/ |
|___/
--------------------------------------------------------------------------------


>> Update

Please choose the update method. For production systems select 'stable'.
The update from svn is only for development systems and may break your current setup.
Note: Update all slave server, before you update master server.

Select update method (stable,svn) [stable]:

--2013-02-26 12:36:46-- http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
Resolving www.ispconfig.org... 78.46.59.59
Connecting to www.ispconfig.org|78.46.59.59|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3312649 (3.2M) [application/x-gzip]
Saving to: “ISPConfig-3-stable.tar.gz”

100%[==============================================================================================================================>] 3,312,649 8.36M/s in 0.4s

2013-02-26 12:36:46 (8.36 MB/s) - “ISPConfig-3-stable.tar.gz” saved [3312649/3312649]

ispconfig3_install/
ispconfig3_install/server/
ispconfig3_install/server/server.php
ispconfig3_install/server/conf-custom/
[...]
ispconfig3_install/helper_scripts/setup_in_openvz/recreate_ssh_and_hostname.sh
ispconfig3_install/helper_scripts/setup_in_openvz/diff_openssl.cnf


--------------------------------------------------------------------------------
_____ ___________ _____ __ _ ____
|_ _/ ___| ___ \ / __ \ / _(_) /__ \
| | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ /
| | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ |
_| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \
\___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/
__/ |
|___/
--------------------------------------------------------------------------------


>> Update

Operating System: Debian 6.0 (Squeeze/Sid) or compatible

This application will update ISPConfig 3 on your server.

Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:

Creating backup of "/usr/local/ispconfig" directory...
Creating backup of "/etc" directory...
Unable to connect to mysql server Access denied for user 'root'@'isp.kdserver.cz' (using password: YES)
MySQL root password [79bca66b37dc9eb90212e5bcbb22a99f]: b6b******3259

Checking ISPConfig database .. OK
Starting incremental database update.
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0027.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0028.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0029.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0030.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0031.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0032.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0033.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0034.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0035.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0036.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0037.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0038.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0039.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0040.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0041.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0042.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0043.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0044.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0045.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0046.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0047.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0048.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0049.sql
Reconfigure Permissions in master database? (yes,no) [no]:

Reconfigure Services? (yes,no) [yes]:

Configuring Database
Configuring Bastille Firewall
Updating ISPConfig
Reconfigure Crontab? (yes,no) [yes]:

Updating Crontab
Restarting services ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld.
Checking for corrupt, not cleanly closed and upgrade needing tables..
Update finished.

#########################################################
#########################################################

tail /var/log/apache2/error.log after update:

[Tue Feb 26 12:54:28 2013] [error] [client 212.96.164.82] PHP Warning: require_once(/usr/local/ispconfig/interface/lib/config.inc.php): failed to open stream: Permission denied in /usr/local/ispconfig/interface/web/index.php on line 31
[Tue Feb 26 12:54:28 2013] [error] [client 212.96.164.82] PHP Fatal error: require_once(): Failed opening required '../lib/config.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/index.php on line 31

#########################################################
#########################################################

This task does not depend on any other tasks.

Closed by  Till (Till)
Wednesday, 27 February 2013, 09:50 GMT
Reason for closing:  Fixed
Preissler Frantisek (Pida)
Tuesday, 26 February 2013, 12:05 GMT
[Tue Feb 26 13:03:24 2013] [error] [client 212.96.164.82] PHP Warning: include_once(): Failed opening '/usr/local/ispconfig/interface/web/tools/lib/interface.d/tpl_default_combobox.menu.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/tools/lib/module.conf.php on line 35

many files missing and log generates too many megabytes with this
Till (Till)
Tuesday, 26 February 2013, 12:38 GMT
> Here is a very big problem to do update with this configuration. I don't know why must be databases localy on each server.

A local mysql database is a system requirement for ispconfig 3 since the first version and described in all multiserver guides. If your setup did not match these requirements, then the update might fail as it is a untested and not supported setup.

> Unable to connect to mysql server Access denied for user 'root'@'isp.kdserver.cz' (using password: YES)

This indicates that the login details for the root user in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf might have been wrong.

> [Tue Feb 26 13:03:24 2013] [error] [client 212.96.164.82] PHP Warning: include_once(): Failed opening '/usr/local/ispconfig/interface/web/tools/lib/interface.d/tpl_default_combobox.menu.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/tools/lib/module.conf.php on line 35

If you use a custom theme, then ensure that your theme has been modified to match the new theming in ispconfig 3.0.5. you can try to switch to the default theme.
Rene Camies (rcamies)
Tuesday, 26 February 2013, 15:54 GMT
Tried three times yesterday evening, all three times, it goes without error, but leaves me with a blank page I the end. IspConfig has died completely at this point. This is on a SINGLE server setup!. I've reverted to 3.0.4.6 by restoring backups from /etc, /usr/local/ispconfig and the db, since that's working and am running OpenSuse 12.2, which should be recent enough.....

So it appears to be a problem on Single machine installs as well...
Preissler Frantisek (Pida)
Tuesday, 26 February 2013, 16:00 GMT
The bug with blank page is because update installer doesn't do permissions settings on copied files.
Till (Till)
Tuesday, 26 February 2013, 16:09 GMT
> The bug with blank page is because update installer doesn't do permissions settings on copied files.

To which exact file do you refer to? I tested it here and all permissions are correct. Maybe you configured a different umask in your shell profile? In this case you can restore the default umask of the linux distribution with:

umask 022

> Tried three times yesterday evening, all three times, it goes without error, but leaves me with a blank page I the end. IspConfig has died completely at this point. This is on a SINGLE server setup!. I've reverted to 3.0.4.6 by restoring backups from /etc, /usr/local/ispconfig and the db, since that's working and am running OpenSuse 12.2, which should be recent enough.....

The opensuse problem is something different and not related to this issue here. The probem on opensuse is caused by a bug in ispconfig 3.0.4.6 and as ispconfig 3.0.5 did not overwrite the fcgi starter script with a correct one, the interface does not show up. The solution for this issue is described here: http://www.howtoforge.com/forums/showthread.php?t=59609
Till (Till)
Tuesday, 26 February 2013, 17:15 GMT
The OpenSuSE issue has its won bug entry now and is fixed in svn stable branch:

http://bugtracker.ispconfig.org/index.php?do=details&task_id=2716&tasks=&project=3&due=73&status%5B0%5D=

Loading...